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1. Introduction

Bend-Tech Design Transfer software allows the User to seamlessly transfer part design data 
from SDS2 to Bend-Tech. Design Transfer works by extracting data from the SDS2 design 
program and remodeling solids. Bend-Tech Design Transfer remodeling feature generates 
high-fidelity geometry, and facilitates improvements to the transfer workflow that benefit the 
fabricator.  

2. Computer Requirements

The user will need the required supporting software in order to run Bend-Tech Design Transfer. 

2.1 Supported Versions
As of September 2023 the supported versions are 2018, 2019, 2020, 2021, 2022, and 2023.

3. Installation

The user will be required to install Bend-Tech Design Transfer software before beginning use. 

The software should be installed to the computer running SDS2. This may not be the Dragon 
computer. 
 

3.1 Installation Process
On the computer where SDS2 is installed, double click on the Bend-Tech icon labeled “Install.” 
This will begin the SDS2 installation procedure. 

Click “Yes” to allow the software to make changes to the computer. 

The Bend-Tech Design Transfer Setup will begin. Click through the series of installation 
popups. 

In the SDS2 Toolbar Configuration popup, choose the configuration(s) you wish to add the 
Design Transfer button to.  Do this by highlighting the configuration and clicking “Add”.  If you 
do not know which configuration(s) you use, it is most likely MODELING-2020.

Choose next. 

Continue to click through the installation popups until installation is complete. 
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4. Installation Troubleshooting

The key to installing Bend-Tech SDS2 Design Transfer is ensuring the user has the latest 
version of SDS2 installed on the computer. If the latest version is not installed, the installer will 
prompt the User to update the software. 

5.  Opening the Application

With a project opened in SDS2, at the top of the Detailing interface, choose the Bend-Tech 
Transfer icon. 

In the part display interface, left click and hold, then drag the window to select the parts that 
will be exported to Bend-Tech. With the parts selected, click ENTER. A Bend-Tech Design 
Transfer interface will open. 

If SDS2 is installed on a server, the Design Transfer button may not appear in the software 
after installation. To manually install the Transfer Button see section 15.

6. User Interface

The parts that were highlighted in the SDS2 Detailing interface will be shown in the Bend-Tech 
Design Transfer parts display.

6.1 Part Log
On the right-hand side of the interface, the Design Transfer software will display a Log of all 
the parts the Design Transfer Software imported from SDS2. 

Success - Parts that were successfully imported will be displayed in green. These are parts 
Bend-Tech software will recognize such as tube and pipe. 

Failure - Parts that were not successfully imported will be displayed in red. These are parts that 
Bend-Tech does not recognize such as I-beam or fasteners. 

6.2 Mouse Actions
Click and hold the scroll wheel, then drag the mouse to move the assembly. 

Right click and hold, then move the mouse to rotate the parts. 
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7. Exporting Process

1.	 Select Transfer Tool button in SDS2 UI
2.	 Select the items to export to the Transfer Tool
3.	 Click ENTER or right click and select OK
4.	 Warnings appear in yellow in the Data Grid. Warning parts require attention from the User 

to resolve. If the part seems OK, you may hit ‘Ignore’ with the warning part(s) selected and 
they will change to a ‘Success’.

5.	 Fixable parts can be isolated with the ‘Fix’ filter.
6.	 Error Parts are highlighted Red and will not save. 
7.	 Click SAVE. The software will save all parts under the ‘Success’ filter as an .enc file, or 

if ‘Write Parts to Individual Files’ was checked in settings all parts will be saved to the 
selected directory.

At the top left of the Bend-Tech Design Transfer interface, choose SAVE. This will export the 
parts/assembly as a file that can be imported to Bend-Tech software. 

8. Transferring to Bend-Tech Software

8.1 Importing the Transfer File
After exporting the file as an .enc file. Open the Bend-Tech software and click IMPORT from 
the Main Task Menu. Select the .enc file and click OPEN. 

This will load the part(s) into Bend-Tech’s auto importer. Ensure any Temporary Material 
added by the import are made permanent. Go to the Material Library. Uncheck the Temporary 
Material checkbox for each imported material, and click SAVE.

Important
Manual Import options and tools are not available for transfer files.

Note
Transfer files can be quite large and can take a while to load. 
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8.2 Saving the File
Once the parts have been imported into Bend-Tech, they can be saved as nested projects. 
Select the parts from the import list and click NEST PART. Ensure that the selected parts use 
the same material size. This will load the selected parts into a new nesting project. Create a 
new nesting project for each material type. With the nesting project open, click SAVE or go to 
FILE > SAVE AS. Name the project and save it in an appropriate location.

9. Settings 

Open the settings by clicking on the Settings button at the top left of the interface.

9.1 Directory Settings
The Directory is the default directory parts are saved to when you click Save.  You may set this 
by clicking the Set button and navigating to the folder you want, and then clicking OK.
Checking Open Directory on Save will open a file browser in the directory on a successful 
save.

9.2 Write Errors as Geometry
When an Warning/Error occurs the geometry of the part will be saved in the file.  A part will not 
be created from this, but it will be transferred.

9.3 Straight Parts Only
Bends/Elbows will be thrown out completely, only straight sections will be processed.  If you 
change this setting and click Save, it will prompt to re-analyze the data.

9.4 Write Piece Mark
Writing the Piece Mark will add the Piece Mark to each Part Name as a suffix.
i.e. - Member HR01 with Material m001 m001 will now be HR01_m001.  Without this checked, 
it will just be m001.

9.5 Write Parts to Individual Files
Parts can be written to individual files within a folder instead of being saved as a full assembly.

9.6  Write Similar Parts Only Once
Parts with the same Piece Mark in SDS2 will only be written to file once and will import into 
Dragon with an appropriate quantity.

9.7 Display Settings
Under Part Visualization and Background Visualization are settings associated with the display.
The Opaque<->Transparent slider sets the opacity of parts.
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9.8 Software Version
In the lower right-hand corner of the settings window above Save is the Software Version.

10. Part Warning Logs

A Part Warning indicates there was a hole or solid that could not be rendered properly during 
the Design Transfer process. 

Part Warning Log Definition
Could Not Generate Hole Model If there is an issue generating a hole, 

the software will display a Could Not 
Generate Hole Model part warning. 
This indicates the hole may be of an 
invalid type. Valid types of holes are:

•	Standard Round
•	Oversized Round
•	Vent Drain
•	Short Slot
•	Long Slot
•	User Slot 1
•	User Slot 2

Other types of holes will not get 
processed. 

Could Not Generate Solid Model If there is an issue generating a 
smooth solid model the software will 
display a Could Not Generate Solid 
Model part warning. This is a non-fatal 
issue, but it may result in something 
unwanted.

11. Failure Logs

A part failure log indicates there is an error in the geometry of the part, an error in the design or 
the software did not recognize the part as a solid. 

Part Warning Log Definition
There was an error retrieving the 
profile

The software will display this error if 
the part has an unsupported profile or 
if there was an issue with the profile.
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There was an error creating the 
centerline

An error creating the centerline part 
failure typically occurs when importing 
a part made with Bend on Line/Bend 
on Radius, or a bend which only 
changes the model and does not 
have parts split between straights and 
elbows. Currently, Bend on Line and 
Bend on Radius are unsupported.

Unable to generate solid model Occurs when there is a failure to 
create the solid model.

Unable to generate cut model Occurs when there is a failure in 
Boolean cutting operations.

12. Progress Bar Notifications

Progress Bar Notifications inform the User regarding progress of software operations. 

Progress Bar Notifications Definition
Waiting to receive input Design Transfer is waiting for the 

SDS2 Parametric to transfer data.  If 
many parts are selected, this process 
could take a while.

Importing Data Design Transfer is reading and parsing 
the data transferred from the SDS2 
Parametric.

Input data contains no parts The SDS2 Parametric has transferred 
data, but no parts are contained within 
the data.

Analyzing Data has been parsed, now consulting 
the data to create parts.

Creating Parts Data analysis has finished, finalizing 
parts so the user can see log 
information and the solid model 
representations.
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13. Progress Bar Errors

In some cases, Design Transfer progress will encounter an error. The Progress Bar will display 
the error for the User. 

Progress Bar Errors Definition
There was an error while analyzing the 
data

Parts were transferred via the 
Parametric, but some error occurred 
while analyzing those parts and 
yielded no results.

There was an error with the imported 
data

Occurs when the Parametric data is 
not in the correct format.  This can 
occur if the Parametric and Design 
Transfer versions are out of sync.

14. Troubleshooting

In the event your Design Transfer software isn’t working properly, follow these steps.

14.1 Install Microsoft Visual C++ Redistributable Package
Go to Microsoft’s Latest Supported Visual C++ Downloads page and download the x64: 
vc_redist.x64.exe under Visual Studio 2015, 2017 and 2019.  Close all applications, run the 
installer and restart your computer.

14.2 Verify/Install .Net Package 4.5
Verify the version of .Net your computer has installed is up to 4.5.  If you don’t have version 
4.5, you can download the package from Microsoft here.

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
https://www.microsoft.com/en-us/download/details.aspx?id=30653
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15. Manually Installing the Transfer Button

15.1 Installation for 2021 or Newer
1.	 Select Utilities in the main window of SDS2.

2.	 Select Customize Interface.
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3.	 Select the role on the left you would like to add the button to. We are adding to 
Detailer(Modeling).

4.	 Open the Launcher Manager.

5.	  Click Add.
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6.	  Fill out each field as follows:
•	 Button text - DesignTransfer
•	 Hover text - DesignTransfer
•	 Script - Navigate to the folder Design Transfer is installed to (default: C:/Program Files/

Bend-Tech DesignTransfer) and go into the Script folder. 
•	 For SDS2 2021, select DesignTransfer.py.
•	 For SDS 2023 or newer, select DesignTransferpy3.py.

•	 Small Icon - Navigate to the folder Design Transfer is installed to, in the Script folder.  
Select Icon2.png.

•	 Large Icon - Navigate to the folder Design Transfer is installed to, in the Script folder.  
Select Icon1.png.

7.	 Hit OK, then Close.  You should be back to the Customize Interface window.  Select Edit 
next to the Ribbon Configuration.



15Bend-Tech Software Design Transfer Software: SDS2

Revision 7September 2023

8.	  Next to Page, select whichever menu you would like to add the button to. We are adding to 
Tools.

9.	 Add a new Section.
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10.	Rename the Section Bend-Tech.

11.	Under Menu item group, select Parametric Launchers.
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12.	Click the + next to DesignTransfer.

13.	If the interface looks similar to the one shown here, go to File > Save, then File > Quit. Click 
OK.
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Your toolbar should now have the DesignTransfer button on it.

15.2 Installation for 2020 or Earlier
1.	 Open the Modeling window in SDS2.
2.	 Go to Options > Toolbar Confinguration.

3.	 Click on Launcher Manager.
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4.	 Click Add. 

5.	 Next to Script, click the dialog button. 

6.	 Navigate to the folder where the Bend-Tech Design Transfer software is installed. This will 
most likely be C:/Program Files/Bend-Tech DesignTransfer.

7.	 Go into the Script folder, and select DesignTransfer.py
8.	 Do the same for Small Icon, selecting Icon1.png.
9.	 Do again for Large Icon, selecting Icon2.png.
10.	Click OK, and then Close.
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11.	Next to the Launcher Manager button, click on the drop down, and locate Parametric 
Launchers. A Design Transfer Button should be listed. Place this button in a convenient 
spot.

 

12.	Click OK.
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